[rt-users] Template compilation error

doug downham doug.downham at gmail.com
Tue Oct 7 10:09:32 EDT 2014


I'm slightly stumped here.
I'm trying to setup a user response survey with a token following the
instructions at
http://requesttracker.wikia.com/wiki/RemoteControlLimeSurvey2
Now, I know the instructions are written for 3.8. I'm running 4.2.6, but
looking at the documentation for the two, it looks like the 3.8 template
should still be valid in 4.2.6.

I've had no trouble setting up LimeSurvey; I've used it many times in the
past with good result. Using the sample code provided, substituting in the
correct values for my environment, I'm getting a "Couldn't compile template
codeblock" error when creating the template, followed by the code I've put
in, followod by "Modification of a read-only value attempted at
/usr/local/share/perl5/Log/Dispatch/Output.pm line 39. Stack:
[/usr/local/share/perl5/Log/Dispatch/Output.pm:39]
[/usr/local/share/perl5/Log/Dispatch.pm:214]
[/usr/local/share/perl5/Log/Dispatch.pm:167]
[/usr/local/share/perl5/Log/Dispatch.pm:145] [(eval 13358):17]
[/opt/rt4/share/html/Admin/Global/Template.html:101]
[/opt/rt4/share/html/Admin/autohandler:49]
[/opt/rt4/sbin/../lib/RT/Interface/Web.pm:682]
[/opt/rt4/sbin/../lib/RT/Interface/Web.pm:370]
[/opt/rt4/share/html/autohandler:53]"

The debug logs for RT and Apache show nothing for this, so I'm stumped.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20141007/453c288b/attachment.html>


More information about the rt-users mailing list