[rt-users] Trouble/Error with Web deployment httpd/apache/mod_fcgid

dwdixon dwdixon at umich.edu
Mon Nov 23 15:57:59 EST 2015

This was sort of the problem....basically I installed many Perl modules via
cpanm and apparently that's a problem in certain circumstances which I'm not
totally sure about at this time.  To fix this error I installed the CentOS
@epel repo version of a few packages:

perl-UNIVERSAL-require.noarch..........0.13-12.el7......... at epel           
perl-Log-Dispatch.noarch.................... 2.41-1.el7.1........ at epel                

These are from @epel (as shown above) but now I'm stuck with an error based
on a perl module that does not have a package published in the epel repo:

Can't locate /Symbol/Global/Name.pm/ in @INC (@INC contains:
/root/perl5/lib/perl5/ /opt/rt4/sbin/../local/lib /opt/rt4/sbin/../lib
/usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
/opt/rt4/sbin/../lib/RT/Config.pm line 57.
BEGIN failed--compilation aborted at /opt/rt4/sbin/../lib/RT/Config.pm line
Compilation failed in require at /opt/rt4/sbin/../lib/RT.pm line 159.

After getting this I searched the repo's for this package, I found and
installed this one:

perl-Symbol-Util.noarch             0.0203-4.el7               @epel

But this did nothing for me and doesn't seem to be what RT/Perl/httpd
wants.....So...It looks like I will have to build a package for the module
"Symbol::Global::Name" that I can install with yum......I tried the hacked
up solution suggested in the blog post you referenced, the OP said in the
quote below that this fixed it for him but I had no luck, it's a hacked in
solution anyhow....

"I fixed the issue by adding the following line in ther perl script before
any 'use' command."

use lib "/root/perl5/lib/perl5/" ;

Looks like your suggestion of installing a separate instance of perl that's
dedicated to RT is making more and more sense the deep down the rabbit hole
that I travel....I'm afraid that if I install a new separate instance of
perl it will break even more things since I suppose I probably have to
recompile RT after doing so and I don't want to lose the configuration state
of RT/RT-IR.....

I just saw Bill Cole's reply and it is EXCELLENT!!! I'm still re-reading to
comprehend but Bill if you get this reply I was drafting prior to seeing
your response so if you need to update your great info based on what I've
said here I'd be very grateful!!


View this message in context: http://requesttracker.8502.n7.nabble.com/Trouble-Error-with-Web-deployment-CentOS-httpd-mod-fcgid-tp60979p60997.html
Sent from the Request Tracker - User mailing list archive at Nabble.com.

More information about the rt-users mailing list