[rt-users] RT 4.4.RC3

Max McGrath mmcgrath at carthage.edu
Mon Jan 11 15:28:29 EST 2016


Hello -

I just upgraded from RT 4.4 RC2 to 4.4 RC3 in my test environment.  I had
an issue in RC2 that I still have in RC3.

I go to the login page and enter my credentials -- I immediately get sent
to https://10.2.1.45/rt/NoAuth/Login.html -- and the page says "*An
internal RT error has occurred. Your administrator can find more details in
RT's log files.*"  However, I can refresh the page and I will be logged
into RT just fine.

The rt.log file shows quite a bit of stuff (mostly debug and info stuff).
But near the bottom it shows:

[24618] [Mon Jan 11 20:31:59 2016] [error]: RT::User::ExternalAuthId
Unimplemented in RT::Record. (/opt/rt4/sbin/../lib/RT/Record.pm line 958)

Stack:
  [/usr/local/share/perl/5.14.2/DBIx/SearchBuilder/Record.pm:494]
  [/opt/rt4/sbin/../lib/RT/Record.pm:958]
  [/opt/rt4/sbin/../lib/RT/Authen/ExternalAuth.pm:522]
  [/opt/rt4/sbin/../lib/RT/Authen/ExternalAuth.pm:424]
  [/opt/rt4/share/html/Elements/DoAuth:57]
  [/opt/rt4/sbin/../lib/RT/Interface/Web.pm:308]
  [/opt/rt4/share/html/autohandler:53]
(/opt/rt4/sbin/../lib/RT/Interface/Web/Handler.pm:208)

Any help?
--
Max McGrath  <https://www.linkedin.com/pub/max-mcgrath/1b/3a6/a21>
Network Administrator
Carthage College
262-552-5512
mmcgrath at carthage.edu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20160111/3ad4bda2/attachment.html>


More information about the rt-users mailing list