[rt-users] Fetchmail

Dunbar, Brian Brian.Dunbar at von.ca
Tue Jul 5 14:16:50 EDT 2016

I think the problem is RT-Mailgate is corrupt  I tried running /opt/rt4/bin ./rt-mailgate –help and it stops with
:/opt/rt4/bin$ sudo vi rt-mailgate
:/opt/rt4/bin$ ./rt-mailgate --help
syntax error at ./rt-mailgate line 71, near "test:"
syntax error at ./rt-mailgate line 74, near "comments:"
BEGIN not safe after errors--compilation aborted at ./rt-mailgate line 79.

The relevant lines from rt-mailgate

     71 service.test:         '|/opt/rt4/bin/rt-mailgate --queue service.test --action correspond
     72               --url http://server/rt';
     74 servicetest.comments: '|/opt/rt4/bin/rt-mailgate --queue service.test --action comment
     75               --url http://server/rt/';
     77 package RT::Client::MailGateway;
     79 use LWP::UserAgent;

From: trevorthorpe at gmail.com [mailto:trevorthorpe at gmail.com] On Behalf Of Trev
Sent: Tuesday, July 5, 2016 11:33 AM
To: Dunbar, Brian
Cc: rt-users at lists.bestpractical.com
Subject: Re: [rt-users] Fetchmail

If your queue contains spaces in it, you may consider using single quotes:

poll oa-internal.domain.com<http://oa-internal.domain.com> protocol imap username "rt-correspondance" password "my_password" mda "/opt/rt4/bin/rt-mailgate --queue 'IT General' --action correspond --url http://rt.domain.com/" no keep

On Tue, Jul 5, 2016 at 11:22 AM, Dunbar, Brian <Brian.Dunbar at von.ca<mailto:Brian.Dunbar at von.ca>> wrote:
Hello RT_Users,

I have exim4 working to send mails from RT and I am trying to use fetchmail to poll exchange and collect the messages.
Fetchmail returns  Fetchmail MDA returned nonzero status 2 in the syslog. I also get POP3 Protocol error 19
I look at the exchange account and I can see that fetchmail is reading the messages.

I have also tried with imap and get error writing to mda broken pipe

Here is the fetchmail config

set daemon 30:
set invisible
set no bouncemail
set syslog

poll mail.server.ca<http://mail.server.ca> protocol pop3
auth password
username "xxxxxxx at server.ca<mailto:xxxxxxx at server.ca>" password "xxxxxxxx"
mda "/opt/rt4/bin/rt-mailgate --queue xxxxxxx --action correspond --url http://xxxxxxx/"
no keep
#sslfingerprint "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"

reading message xxxxx at server.ca@mail.server.ca:9<mailto:xxxxx at server.ca@mail.server.ca:9> of 10 (3310 octets) (log message incomplete)
not flushed

RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Los Angeles - September, 2016

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20160705/3d6cae31/attachment.htm>

More information about the rt-users mailing list