[rt-users] Unable to connect to MySQL during RT upgrade

Alex Hall ahall at autodist.com
Mon Oct 10 18:07:46 EDT 2016


After a few more repeats of some of the below steps, suddenly things
worked. I'm embarrassed to say I may have forgotten to specify rt441.* when
granting privileges, instead only entering rt441. In any case, the upgrade
finally ran, and I appear to be okay, save one thing: those RT_SiteConfig.d
files. They're there, but I can't figure out how to make them apply. The
'update-rt-siteconfig' command still seems to be working on the 4.2.8
install, not the new 4.4.1. I'm not sure how to get it to work on the new
install.

On Mon, Oct 10, 2016 at 5:07 PM, Alex Hall <ahall at autodist.com> wrote:

> Hello list,
> I'm upgrading from the Debian RT 4.2.8 package to the source 4.4.1, and am
> stuck at the 'make upgrade-database' step. When I enter the root password,
> my version, and 'y' to have it begin, it immediately says it can't connect
> and exits with code 255. Here's what I've tried thus far, in no particular
> order:
>
> * restore my backup of the 4.2.8 database to the rt441 database
> * change the username for the RT MySQL account from rtuser (which 4.2.8
> used) to rt_user, since that's what the RT_Config.pm file has
> * change rt_user's password to match what's in the config file (that is,
> PASSWORD('pwd'))
> * moved 4.2.8's configuration files to /opt/rt4/etc/RT_SiteConfig.d, but I
> can't figure out how to apply them
> * checked that no one else is connected to MySQL (they're not)
> * restarted and then stopped request-tracker4, stopped the FCGI server for
> 4.2.8, and restarted Nginx
> * granted full privileges on rt441 to rt_user, then flushed privileges
>
> I'm out of ideas. Can anyone suggest why the upgrade can't log in? I know
> the account works, because I can use rt_user to log into MySQL directly,
> using the same password as in the config file. What have I missed?
>
> --
> Alex Hall
> Automatic Distributors, IT department
> ahall at autodist.com
>



-- 
Alex Hall
Automatic Distributors, IT department
ahall at autodist.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20161010/a258cba2/attachment.html>


More information about the rt-users mailing list