[rt-users] Identifying database credentials in use during upgrade?

Alex Hall ahall at autodist.com
Mon Oct 24 08:09:38 EDT 2016


Hello list,
As I mentioned, the upgrade on my test server from 4.2.8 to 4.4.1 went
well. On the production server, though, it's not; the upgrade-database
script is failing when it tries to connect to the database. I've been in
MySQL messing around with user permissions, trying to get things to work,
but to no avail.

How can I know exactly what username/password the script is using? It says
in the error that the user is 'rt_user', yet in /opt/rt4/RT_Config.pm the
configuration comment says it should be 'rtuser' (note the lack of an
underscore). It may be important to say that this line remains unchanged no
matter how often I re-run ./configure with new options. On a related note,
I have no idea what password is in use since it won't take my configuration
command.

I'm not sure what to try next. Do I erase RT_Config.pm and re-run
./configure? Is there a different way to "start over"? I've already run
'make upgrade' and am now trying to upgrade my database. As directed,
though, I'm operating on a duplicate of my 4.2.8 database, not the
original. Thus I should be able to return functionality to 4.2.8 for the
work day today so people can use it with no problem. I was trying this over
the weekend and early this morning, figuring it wouldn't be hard after my
test went so well. Thanks in advance for any ideas anyone has.

-- 
Alex Hall
Automatic Distributors, IT department
ahall at autodist.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20161024/00193cbb/attachment.html>


More information about the rt-users mailing list