[rt-users] error when using custom template

Landon Stewart lstewart at internap.com
Wed Oct 26 16:25:58 EDT 2016


Add this directly above or below the Subject line in the template but before the blank line.


Content-Type: text/html

On Oct 26, 2016, at 12:15 PM, Alex Hall <ahall at autodist.com<mailto:ahall at autodist.com>> wrote:

Hello list,
I'm starting to test a custom template. When RT tries to use it, I see an error appear in the system log:

Use of uninitialized value in substitution (s///) at /opt/rt4/sbin/../lib/RT/Transaction.pm line 362

That line seems to be detecting any form of new line it can, so how could my template possibly cause such an odd problem? This is my first stab at custom templates; my boss doesn't want quoted text, so he wants reply links in the body of notification emails that people will use in place of standard email replies. I've pasted the text of my template below:


Subject: {$Transaction->CreatorObj->Name} Updated Ticket {Ticket->id}

Ticket {$Ticket->id} was updated (
<a href="mailto:{$Ticket->QueueObj->CorrespondAddress}">click here to reply</a>):

{$Transaction->Description}

Please do not reply to this message. Instead,
<a href="mailto:{$Ticket->QueueObj->CorrespondAddress}">click here to reply</a>,
or
<a href="{$RT::WebAuthURL}/Ticket/Display.html?id={$Ticket->id}">open this ticket on the ticket site</a>.


--
Alex Hall
Automatic Distributors, IT department
ahall at autodist.com<mailto:ahall at autodist.com>
---------
RT 4.4 and RTIR training sessions, and a new workshop day! https://bestpractical.com/training
* Boston - October 24-26
* Los Angeles - Q1 2017

--
Landon Stewart
Lead Analyst - Abuse and Security Management
INTERNAP ®
📧 lstewart at internap.com<mailto:lstewart at internap.com>
🌍 www.internap.com<http://www.internap.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20161026/7610a0ad/attachment.html>


More information about the rt-users mailing list