[svk-devel] Error using 'svk push' vs svn.perl.org

John Peacock jpeacock at rowman.com
Sun Jan 14 21:33:39 EST 2007

I've tried to clean up the messy tags folder for my version.pm repository on
svn.perl.org.  I wrote a script to automate retrieving the log entries to
provide me with content to edit so that the tag log messages would be distilled
down from the mainstream development log messages.

I copied the /version/mirror/tags directory to /version/local/tags and proceeded
to create my new structure.  However, when I tried to push those changes back to
the mirrored repository, I got this:

> ===> Auto-merging (335, 336) /local/tags to /mirror/tags (base /local/tags:335).
> Merging back to mirror source https://svn.perl.org/modules/version.
> A + RELEASE_0.36
> New merge ticket: e4332bfa-8d13-0410-89ef-e8d4c1f66049:/local/tags:336
> Merge back committed as revision 8587.
> RA layer request failed: REPORT request failed on 'https://svn.perl.org/modules/version': REPORT of 'https://svn.perl.org/modules/version': 501 Method Not Implemented (https://svn.perl.org) at /usr/lib/perl5/site_perl/5.8.8/SVK/Mirror/Backend/SVNRa.pm line 310.

which has left the files in the remote repository is quite a state (i.e. I've
got some but not all of the new tags and all of the old ones, since the push
which should nuke those paths wasn't executed yet).

Do I need to pressure Ask to upgrade svn.perl.org?  Should I recreate my mirror
using Subversion 1.4.2 and try again (ARGGH!)?



John Peacock
Director of Information Research and Technology
Rowman & Littlefield Publishing Group
4501 Forbes Blvd
Suite H
Lanham, MD 20706
301-459-3366 x.5010
fax 301-429-5747

More information about the svk-devel mailing list