[rt-users] Web Interface Doesn't Work

Charlie Brady charlieb at aurema.com
Fri Mar 10 00:32:10 EST 2000


On Thu, 9 Mar 2000, Barnett Hsu wrote:

> At 12:01 PM 3/10/2000 +1100, Charlie Brady wrote:
> >That also sounds like a permissions problem. If the RT scripts running
> >from the web server cannot read the transactions, that is how it will
> >look. Go back to the install documentation and check every step.
> 
> I already went through the install documentation
> when I discovered the first problem.  But anyway,
> yes, this one was a permissions problem as well.
> I had to make the transactions directory and all
> of its subdirectories world readable/executable.

You shouldn't need to do that. You should find a solution which works
correctly without being too promiscuous. You may need to change some
ownership, or something else, but you should seek a solution which
is less drastic.

...

> I never expected to have permissions problems --
> permissions were set by the Makefile and I didn't
> change any permissions until after I got the
> "Internal Server Error" pages.  Considering the
> scripts were setuid, I would have thought there
> wouldn't be any permissions problems...

Are you sure that the setuid is working? You aren't mounting via NFS are
you?

Charlie Brady
Aurema Pty Ltd
 PO Box 305, Strawberry Hills, NSW 2012, Australia
Email:charlieb at aurema.com, Tel: +61 2 9698 2322, Fax: +61 2 9699 9174
  "I think it would be a good idea." Gandhi, on Western Civilisation.






More information about the RT-Users mailing list