[rt-users] RE: mod_perl problems

Jim Ficarra jficarra at crosscurrent.com
Sat Jun 22 14:02:02 EDT 2002


I had the exact same problem on Redhat 7.2 and 7.3. Jump to the solution
below if you don't want to read the background:

Background:
I had previously installed a working RT 2.0.12 & RT 2.0.13 on RH 7.2 w/ perl
5.6.0.  Apache and mod_perl were the RPMS from the Redhad CD.  I downloaded
Redhat's RPMS to update mod_perl to 1.26 and perl to 5.6.1, as well as the
other requird modules.  Once I restarted apache after the upgrade, the
process was killed, nothing in the error log, no messages on the console,
etc.  I too commented out the PerlRequire line loading the webmux.pl and
apache started.

I then went through and inserted print statements through the webmux.pl and
the httpd.conf with embedded <perl> tags to see if it was bombing out a a
particular point.  It made it all the way to the bottom, but still bombed
out.  Interestingly enough there was a difference between commenting out the
webmux.pl....the print statements were executed twice implying that the
httpd.conf was processed twice?  Maybe this is an apache thing that I"m not
aware of? Anyway, with the webmux.pl in the print statements were only
executed once.

I tried the same with a fresh install of redhat 7.3 (comes with mod_perl
1.26 and perl 5.6.1)..I figured the upgrade clobbered something so I would
start off fresh. Same thing.  Running httpd -l, telneting to port 80 &
executing a get command, as well as successful starts of apache w/ webmux.pl
commented out showed that mod_perl was running.  It was running as a DSO.

Solution:
I ended up ditching the RPMs and compiling mod_perl 1.26 statically in
apache 1.3.24.  Everything works just fine now.  I read a lot on the web
that indicated that mod_perl as a DSO can be unstable (apologies if my lack
of Apache/Perl/Unix experience is showing through). I was going to try
FASTCGI but other things I read on the RT site said that RT works best with
mod_perl.

-Jim


>Michael Polivanov wrote:
>
>Message: 15
>Date: Thu, 20 Jun 2002 17:24:38 +0200 (CEST)
>From: "Michael Polivanov" <misk at g-zone.at>
>To: <rt-users at lists.fsck.com>
>Subject: [rt-users] mod_perl problem?
>
>
>
>I tried to install Request Tracker 2.0 on my Debian machine today: i
>used only available DEB packages. After i configured the config.pm and
>modified my apache configuration, i tried to restart the apache.
>Nothing. The process was killed, but did not came back up.Nothing was
>logged, also no error messages on console.  After some hours of playing
>with configuration i figured out that after removing "PerlRequire
>/usr/..../webmux.pl" the apache worked again, but, of course, RT not.
>Any ideas? I would like to track down the problem but i do not know how
>i can do it.
>
>regards,
>--michael






More information about the RT-Users mailing list