[rt-devel] Bugs

Alan Boyd mystara at sirius.s-s.org.uk
Sat Mar 4 16:02:04 EST 2000

On 4 Mar 2000, Brandon S. Allbery wrote:

> > else
> > endif
> > 
> > Is changed to:
> > 
> Which is a no-op, and works only by chance.  The real problem is that
> it assumes GNU make (then again, Sun's make has enough pathological
> behavior that you should install GNU make anyway).

I realise that, but I've now tried it on 4 servers, and none of them have
appreciated your ifdef statements.  That was the only way I could get it
to work.
> > 2.) Your script (after installation) gives a large number of Internal
> > Server errors with the message: Premature end of script headers
> Check the web server's error log and you'll probably find that you are 
> missing one or more Perl modules.  Or you have the wrong version of
> CGI.pm (symptom being an error with CGI::Vars).

I did, the premature end of script header errors were the ones in the
error log file.  CGI.pm is installed - version 2.56

> > Also, mailing the script no longer seems to work.  I get a 'User Unknown'
> > email back, with the information:
> > 
> >    ----- The following addresses had permanent fatal errors -----
> > "|/home/rt/test2/bin/rt-mailgate general correspond"
> >     (expanded from: <rt at sirius.s-s.org.uk>)
> > 
> >    ----- Transcript of session follows -----
> > Could not send mail :(
> Nice useful error message your mail server has.  Yet another bizarro MTA?
> Likely problems:
> (1) the rt wrapper isn't setuid;
> (2) the mailer is paranoid and won't run arbitrary binaries
> (i.e. sendmail with smrsh);
> (3) rt-mailgate failed with some other error, likely related to
> missing
> Perl modules.

Well, I seem to remember seeing the 'Could not send mail :(' line in one
of your scripts, after which came $!

The rt wrapper is setuid (after I deleted the blank lines and forced the
decision at the top, the makefile ran fine - so if it was in there chances
are it's worked - I didn't get any errors)

I don't think there are any missing perl modules.  Perl is very heavily
used here, as is MySQL and we haven't had any errors like this one as yet.

I've also just mucked up my databases...I used the same username and
changed the password in the Makefile, which MySQL is none too happy about.
Even though they are different databases :(


More information about the Rt-devel mailing list