[rt-users] Web Interface Doesn't Work

Barnett Hsu hsub at softhome.net
Fri Mar 10 00:20:50 EST 2000

At 12:01 PM 3/10/2000 +1100, Charlie Brady wrote:
>That also sounds like a permissions problem. If the RT scripts running
>from the web server cannot read the transactions, that is how it will
>look. Go back to the install documentation and check every step.

I already went through the install documentation
when I discovered the first problem.  But anyway,
yes, this one was a permissions problem as well.
I had to make the transactions directory and all
of its subdirectories world readable/executable.

Then I discovered that if I tried to reply to a
requestor via the web interface, that also results
in the "Internal Server Error" web page.  I ended
up having to make the transactions directory and
its subdirectories be world writable too.  Then
that worked.

I never expected to have permissions problems --
permissions were set by the Makefile and I didn't
change any permissions until after I got the
"Internal Server Error" pages.  Considering the
scripts were setuid, I would have thought there
wouldn't be any permissions problems...

Oh well, thanks to all for the help.

More information about the rt-users mailing list