[rt-users] Post-install RT error

Ben Pitzer ben at netraverse.com
Thu Jun 7 18:55:00 EDT 2001

Hash: SHA1

Thanks for the feedback, but apparently, the problem was with an older
perl install (5.005).  RT was calling a script called DynaLoader.pm, which
in turn was apparently calling libmysqlclient.so.9.  I had upgraded
recently to perl 5.6.1 via CPAN, though, and that version was living in
/usr/local/bin.  I symlinked /usr/bin/perl to that perl executable, and it
all started working.  No more missing libmysqlclient.so.9 errors.  I can
only surmise that the latest installation of MySQL (3.23) is updated past
the point that DynaLoader.pm could handle it.  I'm not familiar with
DynaLoader.pm, and according to my Debian package manager, it was
installed with the perl-5.005-base package.

I hope that might help somebody, and I'll stay around if anyone has any
more questions for me.

Ben Pitzer
Systems Administrator
Email: ben at netraverse.com
Tel:   919-465-6400
Fax:   919-465-6401

On Thu, 7 Jun 2001 bill at daze.net wrote:

> > I removed my MySQL package, and reinstalled it. I also did a 'make
> > uninstall' on the Msql-Mysql-Modules and tried reinstalling it from
> > scratch.  It successfully installed (however the libmysqlclient.so.10 was
> > never removed when I did the 'make uninstall'), however there is still no
> > libmysqlclient.so.9 anywhere on my system.  I still get the same error
> > when trying to execute the rtadmin command.
> If I remember correctly, libmysqlclient is part of the MySQL client
> installation, not part of the perl module (i.e. Msql-Mysql-Modules)
> installation.  I would suggest reinstalling MySQL.
> _______________________________________________
> rt-users mailing list
> rt-users at lists.fsck.com
> http://lists.fsck.com/mailman/listinfo/rt-users
Version: GnuPG v1.0.4 (GNU/Linux)
Comment: For info see http://www.gnupg.org


More information about the rt-users mailing list