[rt-users] Mason not working?

Toby Wahlers toby at vidiom.com
Wed Nov 7 21:11:09 EST 2001

I have tried about every possible permutation of the apache config files, 
but I have only gotten rt to work with the default VirtualHost setup (which 
I don't want).  Mostly I get the index page as source text with a Go! 
button, but with other (mis)configurations I've gotten malformed header 
messages. I'm running Mandrake Linux, which by default has 2 apache servers 
running, one of them a perl proxy. I've looked at all the list archives, 
and a few people have had the same problem, though with different 
configurations.  I want a subdirectory configuration and need to use an 
alternate port, e.g. http://www.myserver.com:81/rt2/, and would like it to 
work with my current dual server config.  Apache has 3 config files, 
httpd.conf, commonhttpd.conf, and httpd-perl.conf. I have the Alias in 
commonhttpd.conf, 'cause that's where it wants to be. I have added 
ProxyPass to the httpd.conf, and have tried <Directory> or <Location> 
setups in all 3 config files, nothing seems to help.  Any ideas?

Also, the manual and list says that you must stop and start apache after 
changes, not restart.  This is true if using apachectl or a HUP.  But many 
apache's start with an /etc/init.d script, whose "restart" is simply "stop" 
then "start", so I assume this should work fine.


More information about the rt-users mailing list