[rt-users] RT 2.0.11, FreeBSD and perl 5.6 port

Matthew Enger matthew at enger.org
Tue Feb 26 08:10:55 EST 2002


I seem to have hit a little problem with RT, I have tried looking
through the mail archives, checking all the perl modules are installed
and still no avail.

I am attempting to install RT 2.0.11 on a FreeBSD box (4.4-RELEASE). I
have installed the perl 5.6 port and installed all the modules under
that perl install. make testdeps is reporting everything ok. (and it is
checking the correct perl).

I have a fresh copy of apache with mod perl (compiled off the perl 5.6)
and every time I load apache, I get:

# ./apachectl start
Segmentation fault - core dumped.
./apachectl start: httpd could not be started.

My apache config is nothing special, I defined RT as follows:

DocumentRoot /usr/local/site/rt2/WebRT/html
ServerName devel.au.enger.org
PerlModule Apache::DBI
PerlFreshRestart On
PerlRequire /usr/local/site/rt2/bin/webmux.pl
<Location />
SetHandler perl-script
 PerlHandler RT::Mason

Does anyone have any ideas what I could do to fix this?

More information about the rt-users mailing list