[rt-users] RH 7 RT 2 make fixdeps problems

Randy Millis (Lists Acct.) rmillisl at enel.ucalgary.ca
Tue Feb 26 17:39:27 EST 2002

> This may or may not help, but when I installed RT on a RH 7.1 system
> there was a major problem with the RH perl version (5.6.0) and the
> version that CPAN tried to install (5.6.1).  (I belatedly discovered
> that you could halt the 5.6.1 installation.)

Anyone know how you halt the install if doing a make fixdeps?

This is the same issue I have it sounds like:

/usr/local/bin/perl is  perl, v5.6.1 built for i686-linux

/usr/bin/perl is perl v5.6.0 built for i386-linux

> Anyway, when I ran testdeps, it wasn't finding the Apache modules that
> you noted below, either.  I ended up having to install these modules by
> hand using the direct perl path command to 5.6.0, (rather than just
> "perl filename") and it then properly installed those modules, testdeps
> was happy, and then the RT install went fine.

I tried /usr/bin/perl -MCPAN -e shell but ran into two failures ant it looks
like one success.

 make testdeps | grep not
Checking for Apache::Cookie....Apache::Cookie not installed.
Checking for Apache::Session 1.53 ....Apache::Session 1.53  not installed.

Anyone haev any ideas what next?

Here's is what I did:

/usr/bin/perl -MCPAN -e shell

cpan> install Apache::Cookie

In file included from apache_request.c:59:
apache_request.h:5:19: httpd.h: No such file or directory
apache_request.h:6:25: http_config.h: No such file or directory
apache_request.h:7:23: http_core.h: No such file or directory
apache_request.h:8:22: http_log.h: No such file or directory
apache_request.h:9:23: http_main.h: No such file or directory
apache_request.h:10:27: http_protocol.h: No such file or directory
apache_request.h:11:25: util_script.h: No such file or directory
make[1]: *** [apache_request.o] Error 1
make[1]: Leaving directory `/root/.cpan/build/libapreq-1.0/c'
make: *** [subdirs] Error 2
  /usr/bin/make  -- NOT OK
Running make test
  Oops, make had returned bad status
Running make install
  Oops, make had returned bad status

cpan> install Apache::Session
BEGIN failed--compilation aborted at
blib/lib/Apache/Session/Serialize/UUEncode.pm line 14.
Compilation failed in require at t/99uue.t line 7.
BEGIN failed--compilation aborted at t/99uue.t line 7.
        Test returned status 2 (wstat 512, 0x200)
Failed Test  Status Wstat Total Fail  Failed  List of failed
t/99base64.t      2   512    ??   ??       %  ??
t/99dbfile.t      2   512    ??   ??       %  ??
t/99file.t        2   512    ??   ??       %  ??
t/99flex.t        2   512     2    2 100.00%  1-2
t/99mysql.t       2   512    ??   ??       %  ??
t/99oracle.t      2   512    ??   ??       %  ??
t/99postgres.t    2   512    ??   ??       %  ??
t/99storable.t    2   512    ??   ??       %  ??
t/99uue.t         2   512    ??   ??       %  ??
2 tests skipped.
Failed 9/18 test scripts, 50.00% okay. 2/86 subtests failed, 97.67% okay.
make: *** [test_dynamic] Error 2
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force

cpan> install DBD::mysql

All tests successful, 1 test skipped.
Files=18, Tests=764, 22 wallclock secs ( 1.74 cusr +  0.16 csys =  1.90 CPU)
  /usr/bin/make test -- OK
Running make install
Installing /usr/lib/perl5/site_perl/5.6.0/i386-linux/auto/DBD/mysql/mysql.so
Skipping /usr/lib/perl5/site_perl/5.6.0/i386-linux/auto/DBD/mysql/mysql.bs
Files found in blib/arch: installing files in blib/lib into architecture
dependent library tree
Installing /usr/lib/perl5/site_perl/5.6.0/i386-linux/Mysql.pm
Installing /usr/lib/perl5/site_perl/5.6.0/i386-linux/Mysql/Statement.pm
Installing /usr/lib/perl5/site_perl/5.6.0/i386-linux/Bundle/DBD/mysql.pm
Installing /usr/lib/perl5/site_perl/5.6.0/i386-linux/DBD/mysql.pod
Installing /usr/lib/perl5/site_perl/5.6.0/i386-linux/DBD/mysql.pm
Installing /usr/lib/perl5/site_perl/5.6.0/i386-linux/DBD/mysql/INSTALL.pod
Installing /usr/share/man/man3/DBD::mysql.3pm
Installing /usr/share/man/man3/DBD::mysql::INSTALL.3pm
Installing /usr/share/man/man3/Bundle::DBD::mysql.3pm
Installing /usr/share/man/man3/Mysql.3pm
Writing /usr/lib/perl5/site_perl/5.6.0/i386-linux/auto/DBD/mysql/.packlist
Appending installation info to /usr/lib/perl5/5.6.0/i386-linux/perllocal.pod
  /usr/bin/make install  -- OK


More information about the rt-users mailing list