[rt-users] unpriv users... SelfService problems...

David Miller dvmiller at design.ohio-state.edu
Thu Feb 28 16:11:53 EST 2002

I tried Antonio's fix on my server and it did work.  I also took Bruce 
Campbell's advice and checked config.pm for a trailing '/' in any of the 
URLs.  None found except for a couple that are already there in the 
original source.  I saved a copy of the html source of a working 
SelfService page, took out Antonio's changes, and saved the source of the 
non-working page.  Ran diff on the source.  No difference at all.

Took a look at the example apache config for an aliased directory.  Almost 
the same as in the docs, but with one difference.  The docs show this as 
the Alias directive:

Alias /rt2/ /usr/local/rt2/WebRT/html/

I had read the FAQ and had changed it to:

Alias /rt2 /usr/local/rt2/WebRT/html/

as per the entry here: http://fsck.com/rtfm/article.html?id=5#64

I put the trailing slash back in the Alias directive and it worked.  An 
added bonus was that the stylesheet started working as well (it also worked 
with Antonio's changes to autohandler.)

So, which part is acting incorrectly?  For now, I'm making the change to RT 
rather than to apache.

David Miller
Systems Administrator
Department of Design
Department of Art
The Ohio State University

More information about the rt-users mailing list