[rt-users] More on RT 2.0.14 WebRT woes

Gary Oberbrunner garyo at genarts.com
Wed Sep 11 15:18:29 EDT 2002

Problem solved.  I switched the args_method in NewMason11ApacheHandler 
(in /usr/local/rt2/lib/RT/Interface/Web.pm) from 'CGI' to 'mod_perl' and 
now WebRT works perfectly again!  (PerlFreshRestart is on in my config.)

-- Gary Oberbrunner

I wrote:
> Sven Sternberger wrote:
>> after updating I had the same effect, my failure was to remove
>> the line in httpd.conf
>>>> PerlFreshRestart On<<
> Thanks, Sven.
> Unfortunately I've now tried it with and without this line, with no 
> difference.  After tracing the internals a bit I've discovered that 
> $user and $pass are not getting passed through from the form to 
> webmux.pl, so it doesn't even try to authenticate.  It seems in fact 
> that *no* form posting data is getting through to any Mason component. 
> I'm using the latest Mason, 1.13.
> I guess the next thing is to turn on Mason debugging; anyone know how to 
> do that?
> Just for the benefit of other newbies on the list, I've discovered that 
> HTML gets handled in the following order:
> Request for HTML page from browser comes in to apache
> httpd.conf says to use RT::Mason to handle it
> RT::Mason is defined in webmux.pl
> RT::Mason creates handler via RT::Interface::Web::NewMasonApacheHandler
> which calls HTML::Mason::ApacheHandler to do the work.
> ... then some stuff I don't understand yet...
> then Mason passes the HTML request to $RT/WebRT/html/autohandler.  It 
> does whatever it does, then eventually calls $m->call_next, which 
> normally (I think) calls RT::Mason::handler, in webmux.pl.
> But in my case autohandler, which handles authentication, is not getting 
> $user and $pass (or any other form data).  And I guess those are set in 
> the part that I don't understand yet.
> Any hints?

More information about the rt-users mailing list