[rt-users] Login problem, has anyone solved?

Forrest Stanley fstanley at netburner.com
Fri Sep 20 12:35:54 EDT 2002

I notice several other users with this problem, and no one has posted a fix 
for it. I have installed and configured rt2.0.14 with redhat 7.2. When the 
login screen comes up, I enter the correct login (root) and password 
(password) into the login boxes. The problem is, none of these are being 
passed to the next screen. When I hit go, it comes back to the login, 
without even a failed or invalid password statement. Earlier this month 
Gary Oberbrunner solved the problem by changing the args_method in 
NewMason11ApacheHandler (in /usr/local/rt2/lib/RT/Interface/Web.pm) from 
'CGI' to 'mod_perl'. This temporarily solved the problem, and allowed me to 
login. But when I try to post a new ticket I get this error:

error:  Can't call cgi_object() unless 'args_method' is set to CGI.

context:  ...
90:  $RT::Mason::r->content_type($type);
91:  }
93:  sub CGIObject {
94:  $m->cgi_object();
95:  }
97:  }
98:  my ($parser, $interp, $ah);

code stack:  /opt/rt2/bin/webmux.pl:94

This error makes sense, but I am unsure how to fix it. So basically I am 
either looking for a way to get everything passed through with CGI. Or how 
to hack the file so mod_perl works. I appreciate the help that this board 
has given me. :)

-Forrest Stanley

More information about the rt-users mailing list