[rt-users] Is RT 3.x on unmodified OS X 10.3.x possible?

Kevin Murphy murphy at genome.chop.edu
Tue Jan 4 11:12:48 EST 2005

On Jan 4, 2005, at 5:13 AM, B. Derman wrote:
> I gave a quick RT 3.2.2 install attempt, but received compile errors, 
> so
> thought I'd see whether this is a known waste of time before going
> further.


I'm running RT 3.2 on OS X 10.2 (not 10.3), and furthermore I compiled 
perl, apache and mod_perl myself.

I do recall this being rather a pain.

Below are my notes from a year ago (thanks, RT!), in case they are 
helpful in *supplementing* other instructions.  Take my notes with a 
grain of salt, because I am not really a professional sysadmin, and 
furthermore, software changes all the time.

Kevin Murphy

- - -

To prepare for this, I took a snapshot of my current perl modules using 
autobundle command:

perl -MCPAN -e shell
cpan> autobundle

which in this case created a file: /Users/murphy/.cpan/Bundle/

After installing 5.8.3, I probably won't have to use this bundle, but 
it might be safest to
to so, by: 'install Bundle::Snapshot_2004_01_20_00' from inside perl 

-1) First, I installed perl 5.8.3 from source; just follow instructions.

[post hoc note: I usually say good-bye to Apple's version of Perl; not 
sure if this is a good idea or not.  I install perl into /usr/local 
(the default) and rename /usr/bin/perl to something else to avoid 

-1b) I actually did a restore of the snapshot bundle of installed 
modules I took before
the 5.8.3 upgrade. ('install Bundle::Snapshot_whatever' on the CPAN 
module command
line) -- note that this did not actually get everything, I'm not sure 
why: see step 1)

0) I installed mod_perl by following the instructions, i.e.:
perl Makefile.PL APACHE_SRC=../apache_x.x.x/src USE_APACI=1 DO_HTTPD=1 \
make && make test && make install

Then cd ../apache-3.1.29/, and I ran the following script (. 

CC="cc" \
CFLAGS=" -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp 
./configure \
"--with-layout=Apache" \
"--enable-module=so" \
"--activate-module=src/modules/perl/libperl.a" \
"--disable-rule=EXPAT" \
"--disable-shared=perl" \
"--without-execstrip" \
"--enable-module=proxy" \
"--disable-shared=proxy" \
"--enable-module=rewrite" \

1) Taking a snapshot of currently installed modules via the CPAN module 
and restoring
it after upgrading to perl 5.8.3 did not seem to include all the module 
dependencies of
RT. To get everything, I had to do:

sudo perl sbin/rt-test-dependencies --with-postgres --with-modperl1 

(and then do a plain: perl sbin/rt-test-dependencies --with-postgres 
to make sure everything worked).

1b) REMEMBER to put /usr/local/apache/bin at the FRONT of your path 
before installing
any perl modules that might try to interact with Apache, i.e. before 
running perl -
MCPAN -e shell or using the rt-test-dependencies script.

[post hoc note: if you do a standard apache install from source into 
the default location (/usr/local), always remember that you have 
/usr/sbin/apachectl and /usr/sbin/httpd hanging around to trip you up - 
maybe best to rename them and create links into /usr/local.]

2) Everything did NOT work in the rt-test-dependencies step.

2a) In particular, I had to install Apache::TestRun by hand (I wound up 
doing a force
install) -- but that was before I caught onto the trick of putting 
/usr/local/apache/bin at
the front of my path. There might have been a problem of using the 
actual httpd.conf
file - which requires that apache be run as root. These Apache perl 
modules that
require running httpd to test are a pain, because they don't work so 
well if you run them
as root.

2b) I had to install libapreq (obtained from CPAN) by hand. Mother, 
what a pain. The
key was realizing I had to read INSTALL.MacOSX and clue into using:
./configure --with-apache-includes=/usr/local/apache/includes
sudo make install
# and then
perl Makefile.PL -apxs /usr/local/apache/bin/apxs
make test
sudo make install

More information about the rt-users mailing list