[rt-users] Scalar::Util::Weak Problem (Fixed!)

Scott Courtney scott at 4th.com
Mon Feb 13 08:58:50 EST 2006

On Monday 13 February 2006 08:14, jkaufman at footlocker.com wrote:
> It's possible. How does one go about disabling weak references? I was 
> unable to get it to compile using 5.8.7 (self compiled), 5.8.0 (Shipped 
> with AIX), 5.8.5 (Compiled on a previous release of Aix v5.2), and 5.8.7 
> (PDSLIB compile). Nothing worked until I tried 5.8.8 (self compiled).  I 
> can't say I have any idea WHY 5.8.8 worked, but it worked on 
> Scalar::Util::Weak...  Sub::Uplevel is now the problem child :)
> A whole bunch of:
> Use of uninitialized value in string eq at 
> /home/root/.cpan/build/Sub-Uplevel-0.09/blib/lib/Sub/Uplevel.pm line 123.
> It will install, but anything that uses it sometimes will fail their make 
> test...sigh...  Hopefully this will not be a future problem...

I don't happen to have a Perl source tree on my server right now, but there is
a configure-time option in the Perl source that lets you turn this feature on
or off.

Sorry I can't be more help. I'll be the first to admit I'm not a Perl guru.


Scott Courtney         | "I don't mind Microsoft making money. I mind them
scott at 4th.com          | having a bad operating system."    -- Linus Torvalds
http://4th.com/        | ("The Rebel Code," NY Times, 21 February 1999)
                       | PGP Public Key at http://4th.com/keys/scott.pubkey

More information about the rt-users mailing list