[rt-users] Problem upgrading RTFM from 2.0.4 to 2.2.0RC1

Phil Smith III lists at akphs.com
Thu Feb 23 17:02:50 EST 2006

No, it did not.  But I did fight my way to getting it right.  I think the errors (and I'm to blame for most/all of them!) were:

1) The README doesn't mention YAML, so I didn't install it.
2) The 'perl Makefile.PL' either didn't tell me that YAML was missing or didn't make it clear enough.
3) 'make install' (2.2.0RC1) sorta kinda worked but not really.
4) Since the convergence of RTFM and RT in 2.2 made the Custom Fields pages look a lot more similar, it wasn't obvious to me that I was *almost* to the end of the road, and I kept going back.

Ultimately, I went back to square 1 (now that YAML was installed), went through the entire upgrade process (including the rt-setup-database steps, which I think I didn't get to before because the 'make install' failed, and then bloody *FORGOT* about when I went back and 'make install' worked).

The only problem after that was that the Mason cache had to be deleted.  I've been doing this by going to /opt/rt3/var/mason_data/ and doing a 'rm -rf obj' while httpd is stopped.  This was sort of a SWAG; the Mason folks swear up and down that this shouldn't be necessary.  But until I did that, I was still getting results that were clearly due to old, compiled versions being run.

Thanks for your forbearance and help (Jesse, Michael, Todd); I've learned a lot, and in the end, it's now working!


-----Original Message-----
From: rt-users-bounces at lists.bestpractical.com [mailto:rt-users-bounces at lists.bestpractical.com] On Behalf Of Jesse Vincent
Sent: Thursday, February 23, 2006 4:34 PM
To: rt-users at lists.bestpractical.com
Subject: Re: [rt-users] Problem upgrading RTFM from 2.0.4 to 2.2.0RC1

On Thu, Feb 23, 2006 at 04:31:05PM -0500, Michael S. Liebman wrote:
> On Thu, Feb 23, 2006 at 02:43:26PM -0500, Phil Smith III wrote:
> > That second step fails, saying it can't locate YAML.pm.  Indeed, neither can I.

When you typed "perl Makefile.PL" for RTFM, didn't it prompt you to install YAML?

More information about the rt-users mailing list