[rt-users] SetStatus and SetOwner scrip question

Mathew Snyder theillien at yahoo.com
Tue Aug 14 14:34:51 EDT 2007

Stephen Turner wrote:
> At Tuesday 8/14/2007 02:14 PM, Mathew Snyder wrote:
>> I've tried:
>> $self->TicketObj->SetOwner("Nobody");
>> $self->TicketObj->SetOwner(Nobody);
>> $self->TicketObj->SetOwner("10");
>> $self->TicketObj->SetOwner(10);
>> $self->TicketObj->SetOwner(Name => "Nobody");
>> $self->TicketObj->SetOwner(Name => Nobody);
>> $self->TicketObj->SetOwner(Id => "10");
>> $self->TicketObj->SetOwner(Id => 10);
>> None of these has worked and nothing in rt.log indicates any
>> problems.  I have
>> it set up with debug so I know I'm getting as much info as I can.
> Mathew,
> You may be running into something that's bitten us before - let's say
> the ticket is currently owned by "theillien" and you change the queue.
> The scrip will change the owner to Nobody, then the form input is
> processed. RT sees that the owner is Nobody and that the owner field on
> the form is "theillien", so it interprets this as a change from Nobody
> to theillien and you end up where you started. Do you have any entries
> in the ticket history showing any ownership changes?
> Steve


No, I'm not seeing that.  Only two actions are being displayed when I move the

msnyder - Queue changed from CustomerCare to CCEng
RT_System - Status changed from 'open' to 'new'

Nothing saying "Given to ..."

Keep up with me and what I'm up to: http://theillien.blogspot.com

More information about the rt-users mailing list