[rt-users] Perl can't find RT::Mason with WinRT 3.4.5

ComputarUser neomagick at gmail.com
Wed Jun 27 17:36:03 EDT 2007

Hi guys!  I'm stuck.

In short, I'm trying to run WinRT with ActiveDirectory/LDAP authentication
on a WinXP box (150 users; when they log into RT, RT checks with AD,
pulls credentials, and lets them in or not - thats my goal).  WinRT has
Apache and everything for me.  Also, the RT and Apache files are all over
the place,
and take some rooting around for.

The backstory:

Followed the instructions for installing AD by mod_NTLM into RT found at:
But mod_NTLM is *nix only, so it required the SSPI_Auth module instead;
followed install instructions for SSPI_Auth for Apache 2.x at
Made the code changes required by the blank.org link above (Dr.Memory),
with some variations to the httpd.conf file for Auth_SSPI instead of

I can get the initial login to work (Apache asking for login credentials),
but when the WinRT
login page is attempted to be served, the user gets an internal server
error, and apache
spits to the error log:

failed to resolve handler `RT::Mason': Can't locate RT/Mason.pm in @INC
(@INC contains:
C:/Program Files/SecureScout/Request Tracker/winrt/cgi/../../win32/lib
C:/Program Files/SecureScout/Request Tracker/winrt/cgi/../../rt/lib
C:/Program Files/SecureScout/Request Tracker/winrt/cgi/../../winrt/conf
C:/Program Files/SecureScout/Common/perl/lib
C:/Program Files/SecureScout/Common/perl/site/lib .
C:/Program Files/SecureScout/Request Tracker)
at (eval 106) line 3.\n

I'll say right now: I am NOT a perl guru.  To the best of my abilities, I
started tracking down the problem.
http://lists.fsck.com/pipermail/rt-users/2002-January/006383.html and other
similar results told me it was
in webmux.pl.

Line 65 of webmux.pl.in contains:

use lib ( "@LOCAL_LIB_PATH@", "@RT_LIB_PATH@" );

which was not able to find the Mason.pm module (*I think?? Is it seeking
RT.pm?*).  I was only able to determine
this because the next lines seemed to invoke RT and Mason.

Running webmux.pl.in thru perl.exe returns:
perl "c:/program files/securescout/request tracker/rt/bin/webmux.pl.in"
Global symbol "@LOCAL_LIB_PATH" requires explicit package name at
c:/program files/securescout/request tracker/rt/bin/webmux.pl.in line 65.
Global symbol "@RT_LIB_PATH" requires explicit package name at
c:/program files/securescout/requesttracker/rt/bin/webmux.pl.in line 65.
BEGIN not safe after errors--compilation aborted at
c:/program files/securescout/request tracker/rt/bin/webmux.pl.in line 65.

Now, I can't find where Local_Lib_Path and RT_Lib_Path get specified, so I
can't figure out how to add
to that for the whole system.  Furthermore, I don't know which paths to add.

**Here's where things get messy.  If the above is easily answered, please
ignore this.**

Since then, I've tried to include a line that told webmux where to find the
.pm files it was looking for
(both rt.pm and mason.pm).  Problem is, there's a lot of the files of the
same name in the install,
and I don't know which is which.  Some have content, others have different
content, others are blank.
The line I added was:
use lib "C:/Program Files/SecureScout/Request Tracker/win32/lib/WinRT";
with a variety of sources for the path, all of which returned this error in

perl "c:/program files/securescout/request tracker/rt/bin/webmux.pl.in"
Undefined subroutine &RT::LoadConfig called at
c:/program files/securescout/request tracker/rt/bin/webmux.pl.in line 75.
BEGIN failed--compilation aborted at
c:/program files/securescout/request tracker/rt/bin/webmux.pl.in line 77.

Line 75 is RT::LoadConfig(); as a part of :

    #This drags in RT's config.pm
    BEGIN {
        if ($RT::DevelMode) { require Module::Refresh; }

So, I guess it can't find the RT config file?  I've tried every path that
had RT.pm
and/or mason.pm in it, and I still end up with the problem.

I could really use some help.  How/where should I start, and what should I
do from here?  Please
let me know what other info will be of use, and I'll be happy to send it

Thank you!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20070627/f4f12dce/attachment.htm>

More information about the rt-users mailing list