[rt-users] Editing Custom Fields using CLI

Terence Monteiro terence at deeproot.co.in
Thu Apr 3 04:40:49 EDT 2008


I'm using RT 3.6.4, which I had installed using the ubuntu repositiries. I'm
using mysql as the backend DBMS. I have a custom field "Month of application",
which I want to set while creating tickets. The queue I want to create
tickets in has this custom field as one of its fields.

The record for this custom field in the CustomFields table has an id = 31

I found a message on the mailing list saying that editing requires you to give the id,
so I tried:

 rt create -t ticket set Queue="Applications" CF-31="April, 2008"
 # Invalid custom field name (31)
 # Ticket 3620 created.

I also tried using the following methods, but none seems to work:

 rt create -t ticket set Queue="Applications" CF.{"Month of application"}="April, 2008"

 rt create -t ticket set Queue="Applications" 'CF.{Month of application}'="April, 2008"

 rt create -t ticket set Queue="Applications" CF-{"Month of application"}="April, 2008"

Each time I got a message like:

 rt: edit: Unrecognised argument 'CF-{"Month of application"}=August, 2007'.
 rt: For help, run 'rt help create'.
 rt: For help, run 'rt help ticket'.

I checked the source of the rt command line. It seems to be expecting a string without
spaces as the field matching the pattern - [a-zA-Z][a-zA-Z0-9_-]* so it seems to me that
if there is a way to assign custom fields having spaces in them from the CLI, there should
be some way to identify the custom field without supplying spaces. Any comments,
Jesse, Ruslan, Kenneth, anyone?


More information about the rt-users mailing list