[rt-users] Attachment issue (not related to update or else)

Fred Blaise fredb at modernp.com
Thu Dec 18 08:05:44 EST 2008


I got a problematic attachment problem. Files attached are corrupted,
and picture files simple show a link to the picture, but no picture.
Sounds like deja-vu right?

I run RT 3.6.7 on a gentoo system, mysql-5.0.54.

The only things I can see in the logs that could indicate a problem
whatsoever is:
[Thu Dec 18 10:25:26 2008] [warning]: Encode::Guess failed: decoder is
undefined; fallback to iso-8859-1

The tables in the RT database were latin1 charset. I tried to alter all
tables to UTF8, but then, attachments do not even get into the database
anymore (only their reference so to speak, but no binary data).

My RT_config.pm shows:
@EmailInputEncodings = qw(utf-8 iso-8859-1 us-ascii) unless

I also tried to move around the utf-8 and iso-8859-1 values, but nothing

What else can I try to make them work? I saw quite some stuff about
updates on the DB when going to 3.8, but nothing that would concern me

Thanks for any pointers.

More information about the rt-users mailing list