[rt-users] CALLING EXTERNALAUTH TESTERS - v0.07_01 nowavailable.

Mike Peachey mike.peachey at jennic.com
Thu Nov 13 04:39:07 EST 2008

Robert Munsch wrote:
> Still experiencing this.  Not sure what's going on.  Any attempt at
> login for any user - root or otherwise - gets this:
> Undefined subroutine &RT::Authen::ExternalAuth::UserExists called at
> /opt/rt3/local/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAut
> h/autohandler/Auth line 39.
> The difference being only that if I tried logging in as a user that
> doesn't exist yet and should be looked up in AD, refreshing the page
> gives me the login screen again: and if I tried logging in as root, it
> says line 89 instead of 39 and refreshing the page gives me RT at a
> glance successfully.
> Very confused.

I would really like to help, but I'm having difficulty seeing where the
problem might be. It's very much a perl/systemconfiguration/rt-core
problem - I'm much better on ExternalAuth issues.

>> You might want to try, as the user your web server runs as,
>> not root:
>> perl  -I/opt/rt3/local/plugins/RT-Authen-ExternalAuth/lib -
> MRT::Authen::ExternalAuth -e1
> Did that.  No apparent output: just hangs until I ctrl-C.

This could be telling.. though I'm not sure what of.

I know this has probably been mentioned before, but just in case it's
worth at least suggesting:

chown -R apache:apache /opt/rt3

(or whatever is your web user, web group and $RTHOME).
Kind Regards,


Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England

More information about the rt-users mailing list