[rt-users] More: Error code 1 (RT Install on FreeBSD 8)

Zach Boettner zachb at oxfordsuites.com
Fri Dec 18 19:37:05 EST 2009


Two questions:

Why am I not seeing an rt directory under /usr/local/www/ ? And why is my
make clean install returning 'Error code 1' errors at the end of the
following??...

 

===========================

freebsd8# cd /usr/ports/www/rt38

freebsd8# make clean install

===>  Cleaning for p5-Encode-2.39

===>  Cleaning for p5-Class-ReturnValue-0.55

===>  Cleaning for p5-Text-Quoted-2.05

===>  Cleaning for p5-CSS-Squish-0.08

===>  Cleaning for p5-Module-Versions-Report-1.06

===>  Cleaning for p5-Devel-StackTrace-1.22

===>  Cleaning for p5-File-Temp-0.22

===>  Cleaning for p5-Tree-Simple-1.18

===>  Cleaning for p5-HTML-Scrubber-0.08

===>  Cleaning for p5-DBIx-SearchBuilder-1.56

===>  Cleaning for p5-Mail-Tools-2.04

===>  Cleaning for p5-File-ShareDir-1.01

===>  Cleaning for p5-Cache-Simple-TimedExpiry-0.27

===>  Cleaning for p5-Log-Dispatch-2.26

===>  Cleaning for p5-HTML-Parser-3.64

===>  Cleaning for p5-Text-Autoformat-1.666.0

===>  Cleaning for p5-Test-Simple-0.94

===>  Cleaning for p5-Test-LongString-0.11

===>  Cleaning for p5-Module-Build-0.35

===>  Cleaning for p5-XML-Parser-2.36_1

===>  Cleaning for p5-Want-0.18

===>  Cleaning for p5-capitalization-0.03

===>  Cleaning for p5-DBIx-DBSchema-0.36

===>  Cleaning for p5-Class-Accessor-0.34

===>  Cleaning for p5-Clone-0.31

===>  Cleaning for p5-Class-Inspector-1.24

===>  Cleaning for p5-Params-Util-1.00

===>  Cleaning for p5-Params-Validate-0.93

===>  Cleaning for p5-HTML-Tagset-3.20

===>  Cleaning for p5-version-0.78

===>  Cleaning for p5-Text-Reform-1.20

===>  Cleaning for p5-YAML-0.70

===>  Cleaning for p5-ExtUtils-CBuilder-0.27,1

===>  Cleaning for p5-ExtUtils-ParseXS-2.21

===>  Cleaning for p5-Devel-Symdump-2.0800

===>  Cleaning for p5-FreezeThaw-0.45

===>  Cleaning for rt-3.8.6

===>  Found saved configuration for rt-3.8.6

 

      DB_TYPE=type                    mysql, Oracle, Pg or SQLite (mysql)

      DB_HOST=hostname                The database host (localhost)

      DB_PORT=port                    The database port

      DB_DATABASE=dbname              The database name (rt3)

 

      DB_DBA_USER=username            Name of database administrator (root)

      DB_DBA_PASSWORD=password        Password of database administrator

      DB_USER=username                Name of database user for RT (rt_user)

      DB_PASSWORD=password            Name of database password for RT
(rt_pass)

===>  Extracting for rt-3.8.6

=> MD5 Checksum OK for rt-3.8.6.tar.gz.

=> SHA256 Checksum OK for rt-3.8.6.tar.gz.

===>   rt-3.8.6 depends on file: /usr/local/bin/perl5.8.9 - found

===>  Patching for rt-3.8.6

===>   rt-3.8.6 depends on file: /usr/local/bin/perl5.8.9 - found

===>  Applying FreeBSD patches for rt-3.8.6

===>   rt-3.8.6 depends on package: p5-Encode>=2.13 - found

===>   rt-3.8.6 depends on package: p5-Class-ReturnValue>=0.55 - found

===>   rt-3.8.6 depends on package: p5-Text-Quoted>=2.05 - found

===>   rt-3.8.6 depends on package: p5-CSS-Squish>=0.07 - found

===>   rt-3.8.6 depends on package: p5-Module-Versions-Report>=1.05 - found

===>   rt-3.8.6 depends on package: p5-Devel-StackTrace>=1.19 - found

===>   rt-3.8.6 depends on package: p5-Digest-MD5>=2.27 - found

===>   rt-3.8.6 depends on package: p5-File-Temp>=0.18 - found

===>   rt-3.8.6 depends on package: p5-Tree-Simple>=1.04 - found

===>   rt-3.8.6 depends on package: p5-HTML-Scrubber>=0.08 - found

===>   rt-3.8.6 depends on package: p5-DBIx-SearchBuilder>=1.53 - found

===>   rt-3.8.6 depends on package: p5-Mail-Tools>=1.57 - found

===>   rt-3.8.6 depends on package: p5-File-ShareDir>=1.00 - found

===>   rt-3.8.6 depends on package: p5-Cache-Simple-TimedExpiry>=0.27 -
found

===>   rt-3.8.6 depends on file:
/usr/local/lib/perl5/site_perl/5.8.9/Log/Dispatch.pm - not found

===>    Verifying install for
/usr/local/lib/perl5/site_perl/5.8.9/Log/Dispatch.pm in
/usr/ports/devel/p5-Log-Dispatch

===>  Found saved configuration for p5-Log-Dispatch-2.26

===>  Extracting for p5-Log-Dispatch-2.26

=> MD5 Checksum OK for Log-Dispatch-2.26.tar.gz.

=> SHA256 Checksum OK for Log-Dispatch-2.26.tar.gz.

===>   p5-Log-Dispatch-2.26 depends on file: /usr/local/bin/perl5.8.9 -
found

===>  Patching for p5-Log-Dispatch-2.26

===>   p5-Log-Dispatch-2.26 depends on file: /usr/local/bin/perl5.8.9 -
found

===>   p5-Log-Dispatch-2.26 depends on package: p5-Params-Validate>=0.15 -
found

===>   p5-Log-Dispatch-2.26 depends on file:
/usr/local/libexec/apache/libperl.so - not found

===>    Verifying install for /usr/local/libexec/apache/libperl.so in
/usr/ports/www/mod_perl

===>  mod_perl-1.31_1 : Error from bsd.apache.mk. apache22 is installed (or
APACHE_PORT is defined) and port requires 1.3.

*** Error code 1

 

Stop in /usr/ports/www/mod_perl.

*** Error code 1

 

Stop in /usr/ports/devel/p5-Log-Dispatch.

*** Error code 1

 

Stop in /usr/ports/devel/p5-Log-Dispatch.

*** Error code 1

 

Stop in /usr/ports/www/rt38.

*** Error code 1

 

Stop in /usr/ports/www/rt38.

freebsd8#

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20091218/099bc055/attachment.html>


More information about the rt-users mailing list