[rt-users] Try to use ActivePerl

Sven Sternberger sven.sternberger at desy.de
Fri Jul 24 11:07:24 EDT 2009


I tried on a test machine to utilize ActivePerl to get
rid of the RT vs. Operating System package hell.
So I installed ActivePerl and I put the path
to the ActivePerl in front, and started
configure. This looks good.

But 'make testdeps' gives me

/opt/ActivePerl-5.10/bin/perl ./sbin/rt-test-dependencies --verbose
--with-mysql --with-modperl2
	rt group (apache)...found
	bin owner (root)...found
	libs owner (root)...found
	libs group (bin)...found
	web owner (apache)...found
	web group (apache)...found
CLI dependencies:
/opt/ActivePerl-5.10/bin/perl: symbol lookup
error: /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Term/ReadKey/ReadKey.so: undefined symbol: Perl_Tstack_sp_ptr
make: *** [testdeps] Error 127

When disabel CLI in gives me a similar error with dbi
so I tried LD_LIBRARY_PATH but without success, any idea how to fix? 



More information about the rt-users mailing list