[rt-users] callback for Search/Simple.html not working on freebsd

alexander lunev lan at zato.ru
Tue Dec 7 09:47:06 EST 2010


It's FreeBSD 6.2-R, apache-2.2.14, rt-3.8.8

I'm trying to make simple search broader so it will search all tickets 
including resolved, and did as it says in

apache configuration:

<VirtualHost *:80>
     ServerName support.domain.ru

     DocumentRoot /usr/local/share/rt38/html
     AddDefaultCharset UTF-8

     PerlRequire "/usr/local/bin/webmux.pl"

     <Directory /usr/local/share/rt38/html>
         Options Indexes FollowSymlinks
     <Location /NoAuth/images>
         SetHandler default
     <Location />
         SetHandler perl-script
         PerlResponseHandler RT::Mason

FreeBSD port installs RT files under /usr/local/share:

# ls /usr/local/share/rt38
etc     fonts   html    lib     local   plugins po

I created file with callback:


  $$query = $$query . " new open resolved stalled rejected deleted";

  $query => undef

But the magic did not work, search finds only new and open tickets. I've 
tried to put $RT::Logger call in ModifyQuery (though i don't know should 
it work in callback files or not) to test does it even go into this 
file, and nothing appears in logs.

I also tried to put whole path with callback file 
local/html/Callbacks/MyCallbacks/Search/Simple.html/ModifyQuery to 
/var/run/rt38 (where mason_data and session_data resides) with no outcome.

How can i debug this callback to find where the problem is? I've set RT 
to send debug logs to file, and i see nothing suspicious there.

Help please.

best regards
alexander lunev

More information about the rt-users mailing list