[rt-users] Upgrade from 3.6.1 to 3.8.8

Kevin Falcone falcone at bestpractical.com
Fri Dec 10 13:02:27 EST 2010


On Fri, Dec 10, 2010 at 06:48:04PM +0100, Stefan Hornburg (Racke) wrote:
> On 12/10/2010 05:57 PM, Kevin Falcone wrote:
> >On Fri, Dec 10, 2010 at 02:55:40PM +0100, Stefan Hornburg (Racke) wrote:
> >>On 12/10/2010 02:48 PM, Kevin Falcone wrote:
> >>>>We now will be upgrading our Debian server and the version of RT
> >>>>used will go from 3.6.1 to 3.8.8.
> >>>>
> >>>>How feasible is the upgrade from 3.6.1 to 3.8.8?  What would need to
> >>>>be done?
> >>>>
> >>>>Someone has mentioned updates to the DB being needed - I'd
> >>>>appreciate any pointers to the SQL which would be needed.
> >>>
> >>>Have you read through UPGRADING and the README that are included with
> >>>every download of RT?
> >>>
> >>>It covers all of this.
> >>
> >>Not really. It is very important for the upgrade to read UPGRADING.mysql
> >>and follow the steps detailed below:
> >
> >Both of the files I reference contain pointers to UPGRADING.mysql
> >
> >3.8 (3.8-trunk)$ grep UPGRADING.mysql *
> >README:     you're using MySQL, read through UPGRADING.mysql as well.
> >UPGRADING:If you are using MySQL, please read the instructions in UPGRADING.mysql as
> >UPGRADING:New schema for mysql 4.1 and greater, read more in UPGRADING.mysql.
> >
> >-kevin
> >
> 
> Kevin, I just wanted to point this out - many people missed this step because the
> upgrade docs are not clear enough - check the archives :-).

Patches welcome

I've rewritten the docs numerous times due to people being confused.

-kevin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20101210/ef20f0b3/attachment.pgp>


More information about the rt-users mailing list