[rt-users] External Auth (LDAP) and Mail Attribute

Kevin Falcone falcone at bestpractical.com
Tue Nov 15 12:34:26 EST 2011

On Tue, Nov 15, 2011 at 12:21:52PM -0500, Thomas  Misilo wrote:
> -----Original Message-----
> From: rt-users-bounces at lists.bestpractical.com [mailto:rt-users-bounces at lists.bestpractical.com] On Behalf Of Kevin Falcone
> Sent: Tuesday, November 15, 2011 12:05 PM
> To: rt-users at lists.bestpractical.com
> Subject: Re: [rt-users] External Auth (LDAP) and Mail Attribute
> On Tue, Nov 15, 2011 at 11:55:41AM -0500, Thomas  Misilo wrote:
> > 
> > Okay I think I see what my problem is. 
> > 
> > In the log is see "== Attrs: displayName,mail,cn,cn,cn" and when I try and select the attributes like that from the AD it doesn't find them. They are separated by ; I believe with windows AD.
> That's a debugging convention, not the literal command sent.
> The filter is right above it in the logs.
> The usual next step is to run ldapsearch manually with the filter and see what you get back
> -kevin
> Okay I ran;
> ldapsearch -h server-x -b "dc=server,dc=tld" -D "CN=user,OU=Group User Accounts,OU=Groups ,DC=server,DC=tld" -W  "(&(cn=userIwant))" displayName mail cn
> and it displays correctly the following:
> cn: userIwant
> displayName: Name
> mail: userIwant at server.tld
> I have tried changing line 304 in LDAP.pm to join with spaces, but that doesn't work.

Line 304 is a debug line.

It has absolutely no bearing on the operation of the search and

The actual search is run a few lines later.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20111115/35462f1f/attachment.sig>

More information about the rt-users mailing list