[rt-users] Upgrading from RT 3.6.2 to RT 4.0.4

Kevin Falcone falcone at bestpractical.com
Fri Nov 18 12:38:22 EST 2011

On Fri, Nov 18, 2011 at 01:34:37PM +0000, Sean McDaid wrote:
> Hello,
> I'm am working on upgrading from RT 3.6.4rc2 to RT 4.0.4.
> I am having some difficulties with the sequence of instructions provided in
> README, UPGRADING.mysql and version upgrades (UPGRADING-3.6, UPGRADING-3.8
> and UPGRADING-4.0).
> Even though I have MySQL version 4.1 but as I am running RT 3.6 I must
> follow the procedure outlined in UPGRADING.mysql.
> This tells me to follow the instruction in README up to point 6b. In README
> step 2 I have to run "./configure", do I run this with default options or
> specify: "--with-db-database=rt3" (to point to my current database)?

You run it with all the applicable options for your site.

> After this I fix all the required dependencies.
> I skip README 6a as I am upgrading, instead I follow README 6b where I run
> "make upgrade", which works.
> After "make upgrade" it tells me to run "make upgrade-database" which tries
> to connect to rt4 database (with ./configure default) or rt3 database if I
> used "--with-db-database=rt3", both of these fail with:
>    "Access denied for user 'rt_user'@'localhost' to database 'rt3'" OR
> "Access denied for user 'root'@'localhost'" (if I used root)
> I guess I missed something which caused this failure. Any ideas?

Check your permissions configuration to ensure that mysql allows root
and rt_user to connect from localhost, not just over a socket.

> It then directs me back to UPGRADING.mysql step 4 which tells me to apply
> "Apply the RT 3.8 schema upgrades.". Is this "etc/upgrade/
> upgrade-mysql-schema.pl"?

That script outputs sql which you run.

> Are these steps correct? Or is there a worked example of an upgrade frmo
> RT3 to RT4?

You seem to have missed a few steps from UPGRADING-3.6/3.8 which have
you run standalone scripts (like shrinking your cgm/transaction table
and fixing passwords) but in general that seems like the correct flow.

You've read the relevant blog post on the topic?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20111118/b71d8144/attachment.sig>

More information about the rt-users mailing list