[rt-users] Invalid group error on "make upgrade"

Nicôle Layne-Balram nlayne at telebarbados.com
Mon Dec 24 12:55:45 EST 2012

Thanks for responding, 

Top & Ps didn't tell me much so I tried apache as the group, and when that didn't work, I tried root and ran the command directly and that did something, but I think it made things worse:

root at rt:/home/<user>/rt-4.0.8# ./install-sh -m 0755 -o root -g apache -d /opt/rt4/etc
chgrp: invalid group: `apache'
root at rt:/home/<user>/rt-4.0.8# ./install-sh -m 0755 -o root -g root -d /opt/rt4/etc
root at rt:/home/<user>/rt-4.0.8# 

Apache logs:
[Mon Dec 24 17:43:07 2012] [error]: mkdir /opt/rt4/var/mason_data/obj/1972688873: Permission denied at /usr/local/share/perl/5.10.1/HTML/Mason/Compiler/ToObject.pm line 107 (/opt/rt4/sbin/../lib/RT/Interface/Web/Handler.pm:208)

Kind regards,

-----Original Message-----
From: ruslan.zakirov at gmail.com [mailto:ruslan.zakirov at gmail.com] On Behalf Of Ruslan Zakirov
Sent: Monday, December 24, 2012 12:59 PM
To: Nicôle Layne-Balram
Cc: rt-users at lists.bestpractical.com
Subject: Re: [rt-users] Invalid group error on "make upgrade"

On Mon, Dec 24, 2012 at 8:40 PM, Nicôle Layne-Balram <nlayne at telebarbados.com> wrote:
> I'm running into the following error when upgrading from 4.06 to 4.08.
> All dependencies have been found, but when I run "make upgrade" it errors out with the following after re-checking dependencies:
> ./install-sh -m 0755 -o root -g www -d /opt/rt4/etc
> chgrp: invalid group: `www'
> make: *** [config-install] Error 1
> Any ideas? I may have to check which group/user this instance runs apache with?

Probably it's apache/apache, check httpd.conf or ps/top output.

> Kind regards,
> Nicôle

Best regards, Ruslan.

More information about the rt-users mailing list