[rt-users] RT 3.8.11 and AT 2.0.0b upgrade or uninstall and install fresh

Susan McClure smcclure at rice.edu
Wed Jan 11 17:21:48 EST 2012

I have a similar question as Kevin Squire on 12/08/2011 till today.

I tried to install AT 1.2.4b1 on my old system without much success, but
now I have some AT
tables, groups etc in my DB (Postgresql)

I am trying to install AT 2.0.0b from github onto RT 3.8.11 upgraded
I do not have any AT files/scrips in the RT installation.

If I try to do a "make initdb" it fails with the same error:

> Now populating database schema.
> DBD::Pg::st execute failed: ERROR:  relation "at_types" already exists
> ...returned with error: 65280
> make: *** [initdb] Error 255

If I try to do a "make dropdb" to drop the old tables etc, it does not give
any error, or any output, but neither does it drop any AT tables (like
at_assets, at_types, at_ips, at_ports).

I tried a "make realclean" and then tried to install again WITHOUT doing
an initdb.  I ran the upgrade :

>  /usr/site/rt/sbin/rt-setup-database --dba postgres --prompt-for-dba-password --action schema --datadir etc/upgrade/1.2.4

> Now populating database schema.
> Couldn't finish 'schema' step.
> ERROR: Couldn't find schema file(s) '*'

and yes, there is NO schema.Pg file (only mysql and SQLite )

How can I do a complete "uninstall" of Asset Tracker, AND remove the
existing Asset Tracker items from the DB and start over with a fresh

If you tell me all the tables, templates, AT global group and user
rights etc, I could
try to manually drop all the  AT parts from the current DB.


Susan McClure
smcclure at rice.edu

More information about the rt-users mailing list