[rt-users] RT 3.8.11 and AT 2.0.0b upgrade or uninstall and install fresh

Kevin Falcone falcone at bestpractical.com
Wed Jan 11 17:47:09 EST 2012

On Wed, Jan 11, 2012 at 04:21:48PM -0600, Susan McClure wrote:
> I have a similar question as Kevin Squire on 12/08/2011 till today.
> I tried to install AT 1.2.4b1 on my old system without much success, but
> now I have some AT
> tables, groups etc in my DB (Postgresql)
> I am trying to install AT 2.0.0b from github onto RT 3.8.11 upgraded
> system.
> I do not have any AT files/scrips in the RT installation.
> If I try to do a "make initdb" it fails with the same error:
> > Now populating database schema.
> > DBD::Pg::st execute failed: ERROR:  relation "at_types" already exists
> > ...returned with error: 65280
> > make: *** [initdb] Error 255
> If I try to do a "make dropdb" to drop the old tables etc, it does not give
> any error, or any output, but neither does it drop any AT tables (like
> at_assets, at_types, at_ips, at_ports).
> I tried a "make realclean" and then tried to install again WITHOUT doing
> an initdb.  I ran the upgrade :
> >  /usr/site/rt/sbin/rt-setup-database --dba postgres --prompt-for-dba-password --action schema --datadir etc/upgrade/1.2.4
> > Now populating database schema.
> > Couldn't finish 'schema' step.
> > 
> > ERROR: Couldn't find schema file(s) '*'
> and yes, there is NO schema.Pg file (only mysql and SQLite )
> How can I do a complete "uninstall" of Asset Tracker, AND remove the
> existing Asset Tracker items from the DB and start over with a fresh
> install??
> If you tell me all the tables, templates, AT global group and user
> rights etc, I could
> try to manually drop all the  AT parts from the current DB.

Just a reminder that AssetTracker isn't produced by Best Practical, so
while the author may sometimes answer questions on this list, BPS
engineers aren't likely to have easy answers at hand.

The missing upgrade/1.2.4/schema.Pg certainly seems like a bug, but easy
enough to fix with some reading of schema.mysql and the current
definition from etc/schema.Pg. You should certainly file a bug for Todd
with whatever bug tracker he is currently using.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20120111/6f6cd8dc/attachment.sig>

More information about the rt-users mailing list