[rt-users] Name: Hans being found when looking for johansen

Sandra Wittenbrock sandra at hpcrd.lbl.gov
Tue Jul 17 17:25:19 EDT 2012


I just spent, a couple hours trying to find out why when my user sent an
email to create a ticket, it didn't work.  We have been auto-creating
users for a long time without problems. Searching old posts, I was
unable to find one that helped.

The user got both the following messages:

User creation failed in mailgateway: Name in use
User  'johansen at xxx.gov' could not be loaded in the mail gateway

I set in RT_SiteConfig.pm.

Set($AutoCreateNonExternalUsers,    1);

LDAP settings for unique Name and EmailAddress.
 'attr_match_list'           => [    'Name',

The following message in the rt logs suggested to me there could be a
conflict with the user account "hans" and the user account "johansen".
I tried modified the hans account name, but this didn't make any
difference.				]

We have a user "hans".  The log below suggests to me johansen, is
conflicting with hans.

[Tue Jul 17 20:51:02 2012] [debug]: Attempting to use this
canonicalization key: EmailAddress
[Tue Jul 17 20:51:02 2012] [debug]: LDAP Search ===  Base:
dc=xxx,dc=xxx,dc=gov == Filter:
(&(objectClass=*)(mail=johansen at xxx.gov)) == Attrs:
[Tue Jul 17 20:51:02 2012] [info]:
RT::Authen::ExternalAuth::CanonicalizeUserInfo returning Address1: ,
Address2: , AuthSystem: , City: , Comments: , ContactInfoSystem: ,
Country: , Disabled: 0, EmailAddress: hans at xxx.gov, EmailEncoding: ,
ExternalAuthId: hans, ExternalContactInfoId: , FreeformContactInfo: ,
Gecos: hans, HomePhone: , Lang: , MobilePhone: , Name: hans, NickName: ,
Organization: , PagerPhone: , Privileged: 1, RealName: hans, Signature:
, State: , WebEncoding: , WorkPhone: , Zip:

Also, when I search for the user, johansen, or the email address
johansen at xxx.gov, I don't find anything in my RT.  I tried manually
creating the account johansen, but it complains the email address is
already in use. While, at the same time I can't find an account using
that email address. Any ideas why I can't find the user?  I even logged
into mysql, and did an email address search in the Users table.  I also,
sent an email from an newly created yahoo account to double check
account creation, and that worked without a hitch.

Any ideas?



More information about the rt-users mailing list