[rt-users] Linking Articles to Tickets fails for other users

Kevin Falcone falcone at bestpractical.com
Tue Jul 31 12:25:39 EDT 2012

On Tue, Jul 24, 2012 at 05:15:13PM +0200, Jens Danneschewski wrote:
> when linking an article to a ticket, everything works for the person doing the linking.
> If someone else tries to open the ticket he gets the following error message:
> Can't call method "Id" on an undefined value at /usr/share/request-tracker4/lib/RT/URI/fsck_com_article.pm line 135.
> Things we tried:
> - Checking the URI
> o This turned out be wrong, as the OrganizationName was incorrect.
> o Corrected it
> o The URI now looks legit, but still the problem persists
> - Debug log
> o Nothing turns up in the debug-log
> This is it, I can provide more information if someone points me to it...

This either means that RT still doesn't think that the Link matches:
fsck.com-article://$Organization/article/ and is failing to load
or you've got a really weird permissions error going on.

Can other users load the article and see the links back to Tickets?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20120731/5fa9ed9e/attachment.sig>

More information about the rt-users mailing list