[rt-users] Some questions, a few oddities, and some must-haves...

Glenn E. Sieb gsieb at efashionsolutions.com
Thu Jun 7 15:55:21 EDT 2012

On 06/06/2012 10:54 PM, Kevin Falcone wrote:
> Firefox and Chrome's spellcheckers work fine. In fact, I get the 
> highlighting as I type. If that doesn't work, hold control when you 
> right-click to get to your spellchecker menu. 

After being frustrated with the "will control right-click work or not" 
(since it seemed it kind of worked sometimes but not most times here), 
we went and replaced the ckeditor included with RT (in 
/$RTHOME/share/html/NoAuth/RichText/ckeditor with a newer version from 
their website (ckeditor.com). We popped in a 
/$RTHOME/share/html/NoAuth/RichText/ckeditor/config.js that looks like this:

Copyright (c) 2003-2012, CKSource - Frederico Knabben. All rights reserved.
For licensing, see LICENSE.html or http://ckeditor.com/license

CKEDITOR.editorConfig = function( config )
     // Define changes to default configuration here. For example:
     // config.language = 'fr';
     // config.uiColor = '#AADC6E';
     config.scayt_autoStartup = true;
     config.toolbar_Full =
             { name: 'document',    items : [ 
] },
             { name: 'clipboard',   items : [ 
'Cut','Copy','Paste','PasteText','PasteFromWord','-','Undo','Redo' ] },
             { name: 'editing',     items : [ 
'Find','Replace','-','SelectAll','-', 'Scayt' ] },
             { name: 'basicstyles', items : [ 
] },
             { name: 'paragraph',   items : [ 
] },
             { name: 'links',       items : [ 'Link','Unlink','Anchor' ] },
             { name: 'styles',      items : [ 
'Styles','Format','Font','FontSize' ] },
             { name: 'colors',      items : [ 'TextColor','BGColor' ] },
             { name: 'tools',       items : [ 'ShowBlocks','-','About' ] }
config.enterMode = CKEDITOR.ENTER_BR;
config.shiftEnterMode = CKEDITOR.ENTER_P;
config.enableTabKeyTools = true;
config.htmlEncodeOutput = false;

config.disableNativeSpellChecker = false;
config.browserContextMenuOnCtrl = true;

config.toolbarStartupExpanded = true;
config.font_names =
     'Arial/Arial, Helvetica, sans-serif;' +
     'Courier New/Courier New, Courier, monospace;' +
     'Georgia/Georgia, serif;' +
     'Lucida Sans Unicode/Lucida Sans Unicode, Lucida Grande, sans-serif;' +
     'Tahoma/Tahoma, Geneva, sans-serif;' +
     'Times New Roman/Times New Roman, Times, serif;' +
     'Trebuchet MS/Trebuchet MS, Helvetica, sans-serif;' +
     'Verdana/Verdana, Geneva, sans-serif';


This turns on SCAYT by default, and removes the after-the-fact 
spellcheck button which seems to throw errors, and removes other stuff 
we don't necessarily care about (like bullets, forms, etc.).

We also set the toolbarStartupExpanded to true so it was just there for 
our Customer Service reps. Since SCAYT is running by default, they'll 
see their typos, and right-clicking will do what you expect it to, 
without the CTRL key.

>> 2) Is there an extension that lets me define a signature for
>> separate queues? (It can be only per queue, it doesn't have to be
>> per-user.) So, a signature that all emails going out from queueA
>> get, queueB has it's own, queueC it's own, etc.
> There isn't a feature for this in the message editor, but you could
> certainly add queue specific Correspondence templates that contain a
> signature.

True. I suppose I can capture their Real Name as a perl-enabled-scrip 
and pop it in the signature as well. Thanks! :)

>> 3) I run RT 4.0.5 on my home server, and have since version 2. I set
>> up 4.0.5 here at work, and I noticed some oddities. The submenu
>> disappears on submission of a form. (Screen captures are here:
>> http://www.wingfoot.org/gallery/v/Glenn/ges-misc/RT/, pink is the
>> work site, brown is the home server) Needless to say, my users are
>> not liking this, and really, I'm finding it odd.
>> 4) Possibly related to #3, when I go to Tickets/New Search, I'll
>> fill out the criteria area, and hit "Add these terms and search"..
>> blank results. Every time. And no submenu. (So the menu under the
>> "New Ticket in" button that says "Edit Search" etc.) If I put the
>> criteria in as "Add these terms" then click "Show results" in the
>> submenu, I get results. Occasionally, I get the submenu. Oddness.
>> :-/
> There were a few fixes to submenus in 4.0.6.  If you have replication
> recipes for 4.0.6, please file a bug with them.

I'm running 4.0.5, which was the latest release when I installed RT a 
month ago. I will have to try and come up with a maintenance window to 
install 4.0.6 now. :-)

BTW, *my* server (the screenshot with the brown background) is *my* 
server. My *work* server belongs to the company I work for. They do not 
replicate with one another. I merely showed them as a comparison as to 
what seemed weird.

Thanks, Kevin!

Glenn E. Sieb
System Administrator
+1 201 809-4958

80 Enterprise Avenue South
Secaucus, NJ 07094

More information about the rt-users mailing list