[rt-users] spawn-fcgi and rt-server.fcgi fail

Alex Hanselka alex at darkdna.net
Fri Oct 19 15:54:38 EDT 2012

On 2012-10-19 14:48, Alex Vandiver wrote:
> On Fri, 2012-10-19 at 14:25 -0500, Alex Hanselka wrote:
>> You can find that at http://darkdna.net/strace.txt
> Was this from before or after the patch?  I don't see any of the
> expected calls to bind or listen there, which is the problem the 
> patch
> was meant to address.  Can you strace the spawn-fcgi version?

Sorry, this was BEFORE the patch. After the patch is 
http://darkdna.net/rt-server.txt  and http://darkdna.net/spawn-fcgi.txt

to verify it worked, patch output:

# patch -p1 < ./patch.patch
patching file lib/RT/PlackRunner.pm
patching file sbin/rt-server
Hunk #2 succeeded at 141 with fuzz 2.

>> Didn't seem to do anything.  When I do the spawn-fcgi incant, it now
>> says "spawn-fcgi: child spawned successfully: PID: 27689" but 
>> nothing
>> stays running. 27689 doesn't exist.
> How does `/opt/rt4/sbin/rt-server.fcgi --port 9090` fare with the 
> patch?
>  - Alex

Same error after the patch.


More information about the rt-users mailing list