[rt-users] RT on Ubuntu 12

Martin mworia.martin at gmail.com
Wed Feb 20 03:48:32 EST 2013

Paul Tomblin <ptomblin <at> xcski.com> writes:

> On Thu, Jun 21, 2012 at 11:33 AM, Borngunners <borngunners <at> aol.com> 
> > Can't locate JSON.pm in @INC (@INC contains: /opt/rt4/sbin/../local/lib
> > /opt/rt4/local/plugins/RT-Authen-ExternalAuth/lib /opt/rt4/sbin/../lib
> > /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2
> > /usr/lib/perl5 /us
> If you're missing JSON.pm, then you never ran "make testdeps" and
> "make fixdeps" when you installed.
> Go back and install it properly, following *all* the instructions.

Hi paul

Just wanted to share that i recieved the same error

[Fri Feb 15 18:48:12 2013] [error] [client] failed to resolve 
handler `Plack::Handler::Apache2': Can't locate Plack/Handler/Apache2.pm in @INC 
(@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 
/usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 
/usr/share/perl/5.14 /usr/local/lib/site_perl . /etc/apache2) at (eval 2) line 

So i did

apt-get install libplack-perl

next i also encountered the error Can't locate JSON.pm

guys you should know prior to this i ran make testdeps and all dependencies were 

There were other modules missing every time i restarted the apache and i 
installed them before it finally worked

apt-get install libtext-password-pronounceable-perl
apt-get install libjson-perl
apt-get install libregexp-ipv6-perl
apt-get install libregexp-common-net-cidr-perl
apt-get install libdevel-globaldestruction-perl
apt-get install libhtml-mason-psgihandler-perl
apt-get install libcgi-emulate-psgi-perl

Now the problem is i cant login using root and password from the web interface

Some one please give me suggestions.

More information about the rt-users mailing list