[rt-users] RT 3.6.11 CLI and externalauth

John Bartelt bartelt at slac.stanford.edu
Thu Jun 6 13:09:47 EDT 2013

Hello.  I realize RT 3.6.11 is pretty old at this point, but I'm
hoping someone may have an answer for this.  I recently tried to
use the CLI 'rt' command, and authentication is not working. We
use external authentication with our installation.  I'm sure the
CLI was working for us in the distant past (may have been RT 3.0.x).

Currently, though, after prompting for the password, it always says
"rt: Incorrect username or password."

I do have test instances for 3.8.x and and 4.0.x, and those versions
of 'rt' work, because I set 'externalauth' to 1.  But the 3.6
version of 'rt' doesn't support that option.  If I try to use the 3.8
version of 'rt' CLI with the 3.6.11 installation, authentication
succeeds, but it never finds any tickets, e.g.,  for valid 'list'
requests. "No matches found".  So I assume there is some mismatch there.

I turned on debugging and it looks like the initial authentication
succeeds, but no cookie is created/stored, and so any further
interaction is blocked.

I also tried backporting 'externalauth' to the 3.6.1 'rt', but
haven't gotten it to work.

Any help or hints appreciated.

John Bartelt                             bartelt at SLAC.Stanford.edu
SLAC National Accelerator Laboratory     650-926-4591
MS 97
2575 Sand Hill Road
Menlo Park, CA 94025                     office: OCIO room 307

More information about the rt-users mailing list