[rt-users] Unable to configure "open" queue

Joop jvdwege at xs4all.nl
Thu Jun 20 03:45:49 EDT 2013

Christian B. Wiik wrote:
> Hi.
> We are a small company that got recommended this nice piece of 
> software, but have stranded on a small issue: We are unable to 
> configure a "open" queue, that allows everyone to create a ticket 
> through incoming email.
> Whatever we try we get the following two lines in syslog:
> Ticket creation failed: Test 20: No permission to create tickets in 
> the queue 'Testing' (/opt/rt4/sbin/../lib/RT/Interface/Email.pm:248)
> Could not record email: Ticket creation failed: No permission to 
> create tickets in the queue 'Testing' 
> (/opt/rt4/share/html/REST/1.0/NoAuth/mail-gateway
> :75)
> Tried this on both the stock "Support" queue, and now with a brand new 
> "Testing" queue.
> The setting I would suspect should change this, is queues->group 
> rights->All, and then allowing "Create tickets" under "General 
> rights", but I have also tried allowing this a dozen other places 
> without luck :-(
As a test could you add Create Tickets to the global Everyone group and 
then try. RT Essentials (the book) has an example of that and for me it 
has worked several times in the past. Restricting Create Ticket to only 
certain queues will work but try to get the general one working first.
Thinking about general, what does your /etc/aliases look like, or 
how/where does you mail end up in RT?
My setup is that mail send to support at domain.nl will go to the General 
queue which is created as part of initdb and things like 
support-app1 at domain.nl will go directly to the app1 queue. I'm 
suspecting that you have added Create Ticket to your Testing queue but 
that by default your mta is trying to use the General queue to create 
tickets which doesn't have Create Ticket.



More information about the rt-users mailing list