[rt-users] errors in upgrade to rt-4.2

Kevin Falcone falcone at bestpractical.com
Fri Sep 13 09:53:10 EDT 2013


On Fri, Sep 13, 2013 at 01:18:30PM +0000, Xin, Qiao wrote:
>    We failed in upgrading RT from 4.0.5 with RTIR 2.6.1 to 4.2 with the following error. Please help.

I'm confused how you're running 4.0.5 with RTIR 2.6.1, since that
version isn't compatible with RT 4 (RTIR 3.0.0 is the compatible
version).

That old RTIR version appears to be the source of this error as well.

>    [8932] [Thu Sep 12 20:27:33 2013] [critical]: Can't wrap non-existent subroutine
>    RT::Queue::HasRight at /temp/rt-4.2.0rc1/sbin/../lib/RT.pm line 730.
>    Compilation failed in require at /temp/rt-4.2.0rc1/sbin/../lib/RT.pm line 730.
>    (/temp/rt-4.2.0rc1/sbin/../lib/RT.pm:391)

There are some pretty big changes between RT 3.8 (what RTIR 2.6.1 was
designed to work with) and RT 4.2.  We'll be releasing RTIR 3.2.0 to
be compatible with RT 4.2, but not until after the official 4.2.0
ships.

-kevin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 235 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20130913/710ea473/attachment.pgp>


More information about the rt-users mailing list