[rt-users] Fedora 20 / Perl 5.18

Kevin Falcone falcone at bestpractical.com
Tue Feb 18 13:44:35 EST 2014


On Tue, Feb 18, 2014 at 10:11:39AM -0800, CLOSE Dave wrote:
> Good thought but both perl and mod_perl were upgraded at the same time 
> and both are version 5.18. It appears to be RT which is compiled against 
> the wrong version.

RT is not a compiled application.  It runs under the perl that you
tell Apache to use.

The most common type of error is the wrong version of mdo_perl

> Fine. I'm trying to do that. Doesn't seem like it should need more than 
> going to my unpackage directory and running "make install". However, 
> when I try that, I get,
> 
> CORE missing dependencies:
>          Data::GUID ...MISSING
>                  Perl API version v5.16.0 of v does not match v5.18.0 at 
> /usr/lib64/perl5/DynaLoader.pm line 213.
> 
> But the perl-Data-GUID package is /not/ missing.
> 
> # ls -l /usr/share/perl5/vendor_perl/Data/GUID.pm
> -rw-r--r-- 1 root root 8799 2013-12-13 05:23 
> /usr/share/perl5/vendor_perl/Data/GUID.pm
> 
> I suspect I'm missing a step /before/ "make install". Clues?

Those are two different paths.

Ensure that when you're in the upgrade directory you have perl-5.18 in
your path before perl-5.16 before running configure.

You appear to have a few perls and differing 32bit vs 64bit problems.

-kevin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 235 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20140218/0ab41894/attachment.pgp>


More information about the rt-users mailing list