[rt-users] Install/Upgrade issue

Kevin Falcone falcone at bestpractical.com
Thu May 22 16:24:36 EDT 2014

On Thu, May 22, 2014 at 07:58:24PM +0000, Sears, Mark wrote:
>    That worked…actually swapped command around using RHEL.
>    Now I ran into another error doing make-upgrade database

Instead of adding groups, why not just tell RT the right group to use.
You didn't show your configure output where it picked www-data so it's
hard to advise.

Read ./configure --help as suggested in step 2 of the README

$ ./configure --help | grep group
--with-libs-group=GROUP group that will own RT binaries (default bin)
--with-web-group=GROUP  group the web server runs as (default: www)
--with-rt-group=GROUP   group to own all files (default: rt)

>    1) AND (main.ObjectType = 'RT::System')  ORDER BY main.id ASC 'no such table: Attributes
>    (/usr/local/lib/perl5/site_perl/5.20.0/DBIx/SearchBuilder/Handle.pm:556)
>    Couldn't finish 'upgrade' step.

If your database has no Attributes table, it is not a complete RT
database and something went horribly wrong in your copy/restore of it.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 235 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20140522/c65846e3/attachment.sig>

More information about the rt-users mailing list