[rt-users] Quicksearch not displaying queues

Sam Florida sam.florida at gmail.com
Tue Nov 18 15:03:10 EST 2014


Thanks for the response Kevin.  I ran make upgrade-database on the first
import, and of course again as part of the regular upgrade, rather than
attempting to maintain a 4.0.8 database on a 4.2.9 installation.

I had located a previous issue in an rt-users thread which you resolved,
which also appeared to be an RTIR install causing the problem.  That led me
to attempting to disable RTIR queues and articles in the first place.  I do
appreciate the help, as your response led me to review the queues again,
and I had missed disabling the Blocked queue.  As I stated, I was likely
missing something obvious.

Thanks again,
Sam

On Tue, Nov 18, 2014 at 2:41 PM, Kevin Falcone <falcone at bestpractical.com>
wrote:

> On Tue, Nov 18, 2014 at 01:29:13PM -0500, Sam Florida wrote:
> > I'm receiving an error after migrating from 4.0.8 to a new server with a
> 4.2.9
> > install:
> > [error]: Can't call method "Name" on an undefined value at
> /opt/rt4/share/html/
> > Elements/QueueSummaryByLifecycle line 131.
> >
> > Restoring the 4.0.8 database to the new installation appeared to be
> successful,
> > yet Quicksearch failed to display a queue listing.  The aforementioned
> error
> > appears to be the culprit:
>
> I'm not sure how running the 4.0.8 database under the 4.2.9 codebase
> would get you anything but more errors.
>
> This error implies you have a Queue with a lifecycle that is not
> defined in your configuration.  You mentioned RTIR, I suspect those
> queues are not properly disabled.
>
> You can look at:
> select Name, Lifecycle, Disabled from Queues;
> and see which queue exists but doesn't have a Lifecycle in the
> configuration anymore.
>
> -kevin
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20141118/699dfb0a/attachment.html>


More information about the rt-users mailing list