[rt-users] e-mail encoding problem with the Autoreply template

Nikola Hordez nikola.hordez at nettvplus.org
Fri Oct 31 14:05:23 EDT 2014


Hi,

I have a problem with the encoding on Request Tracker 4.0.19 on Ubuntu
14.04.
I recently migrated from mysql to postgreSQL with the RTmysqltoPg script.
When I save a template for Autoreply in a queue that have characters like
š,đ,č..., I receive a reply with gibberish instead of text with š,đ,č,
In the headers of the mail I can see that everything is set to UTF-8.
After investigating a little, I saw that even the table templates in the
PostgreSQL database is wrongly encoded(no invalid byte sequence in the
PostgreSQL logs!), but surprisingly enough the characters are displayed OK
in the web interface of RT (on the template page).
Maybe this is a bug in Perl, so I tried to downgrade the Encode
plugin(version 2.49 and 2.53) from version 2.63, but it;s still the same.
My Perl version is v5.18.2.
I presume that if I manually replace in postgreSQL the characters to š,đ,č
that the mail will be OK, but I can't test it yet on the production server.
Why is Perl not sending the text in the proper encoding format to the
database?
The encoding in PostgreSQL is set for the database to UTF8, the
client_encoding as well.

Thank you in advance!

Best regards,
Nikola Hordez
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20141031/234ee19e/attachment.html>


More information about the rt-users mailing list