[rt-users] spawn-fcgi crashing, is uWSGI an option?

Martin Wheldon martin.wheldon at greenhills-it.co.uk
Mon Jun 15 17:12:50 EDT 2015

Hi Aaron,

I'm running Nginx with uWsgi in my lab environment and it seems to we 
working well.
Here are the snippets of config I'm using.

server {
         root /usr/share/nginx/www;
         index index.html index.htm;

         # Make site accessible from http://localhost/
         server_name localhost;

         location / {
                 uwsgi_pass unix:/var/tmp/uwsgi.sock;
                 include uwsgi_params;
                 uwsgi_modifier1 5;

plugins = psgi
chmod-socket = 664
uid = www-data
gid = www-data
socket = /var/tmp/uwsgi.sock
psgi = /opt/rt4/sbin/rt-server
processes = 10

Best Regards


On 2015-05-31 05:43, Aaron C. de Bruyn wrote:
> Thanks Ken.  It's working perfectly.
> -A
> On Sat, May 30, 2015 at 5:00 PM, ktm at rice.edu <ktm at rice.edu> wrote:
>> On Sat, May 30, 2015 at 04:49:00PM -0700, Aaron C. de Bruyn wrote:
>>> I have a demo of RT set up for my company.
>>> During testing, we found the spawn-fcgi process is slow and crashes 
>>> often.
>>> If more than a few users are on the site, and/or more than few
>>> messages coming in through rt-mailgate, the site loads extremely 
>>> slow.
>>> We increased the number of child processes for spawn-fcgi, but it's
>>> doesn't seem adequate to handle the load.
>>> We can regularly make spawn-fcgi die by simply hitting escape while a
>>> page is loading.  Other times it crashes for no apparent reason.
>>> We use uWSGI everywhere for python projects we host, and I tried to
>>> see if I could get RT working under that.  I failed miserably because
>>> I don't know that much about PSGI, FCGI, etc...and their relationship
>>> to the webserver.  I know Nginx can speak the uwsgi protocol to talk
>>> to uWSGI, but uWSGI seems to bomb on trying to serve RT.
>>> I tried the following config to no avail:
>>> [uwsgi]
>>> plugins = psgi
>>> socket =
>>> psgi = /opt/rt4/sbin/rt-server.fcgi
>>> fastcgi-socket = true
>>> processes = 2
>>> master = true
>>> stats =
>>> chdir = /opt/rt4
>>> uid = uitrt
>>> gid = uitrt
>>> Has anyone else been able to run it using uWSGI?
>>> Are there other options for keeping the site running under nginx?
>>> Thanks in advance for any pointers or advice.
>>> -A
>> Hi Aaron,
>> We run RT with spawn-fcgi/nginx and either systemd/RHEL7 or
>> multiwatch/RHEL6 to make sure that the pool stays populated. No
>> problems at all. I would take uWSGI out of the mix, although there
>> is no reason it should not work, there may be some nuances involved.
>> The fact that the site loads slowly seems to indicate that you are
>> having a problem with your database backend. Check out your slow
>> queries and see what is wrong. It should be pretty zippy by default.
>> Regards,
>> Ken
> !DSPAM:41,556a90bf10567738710544!

More information about the rt-users mailing list