[rt-users] RT unusably slow on iPhone / TLS

Chris Herrmann chrisherrmann7 at gmail.com
Wed Nov 25 04:53:32 EST 2015

Poor form to reply to your own question... just tried Chrome on iOS - much
faster. Firefox refuses to load completely because it's a self signed cert.

On 25 November 2015 at 20:31, Chris Herrmann <chrisherrmann7 at gmail.com>

> hi all,
> I'm really not sure where to start troubleshooting this. If I use a
> computer to access our RT instance, then the speed is good. If I use any
> iPhone, then the speed is terrible. 6S/5S/4S iOS7/8/9 - all terrible. By
> terrible - I mean that the front page might take 10 seconds to load. If I
> tap the username field, it might take a further 10 seconds before I can
> enter text. Each and every tap / submit / etc is unusably slow. The key is
> a 2048 RSA which should be OK on an iphone.
> It *feels* like a site that's using horrible javascript, making the
> browser unresponsive. But on an iPhone I really have no way of testing this
> (well that I'm aware of).
> We're running it on nginx, TLS, self signed cert - signed by an internal
> CA that is trusted by the phone. I've tried things ranging from spdy
> (html/2 not supported on iphone), loading the pem with all of the certs in
> the chain, enabling caching of static objects - no difference.
> Just to be clear - it's fast on a regular PC / browser. Just slow on
> phones (mobile & regular interface) - slow regardless of location (i.e.
> wifi in the office to the server, 4G... no difference).
> any ideas where I should look? or what do i need to tell you... to try and
> get help?
> Thanks!
> Chris
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20151125/c5a8696d/attachment.htm>

More information about the rt-users mailing list